
System Response Using MATLAB Simulink 

 

1.1 The notion of system. General properties of systems. 

The term system is a notion that covers an extremely wide variety of objects or processes 

that take an input signal, transform it, and then further transmit the processed signal as an output 

signal, also called the system's response to the input signal; thus, the system is a functional 

block that has one (or more) inputs and one (or more) outputs. These signals can be several 

types of quantities, not necessarily all of the same type, including electrical quantities such as 

instantaneous voltage, current or power, thermal quantities such as temperature or heat, 

mechanical quantities such as force or pressure, and information -quantities measured in bits. 

Next, we consider systems with one input and one output, both electrical quantities, as shown 

in Fig. 1. 

 
Fig. 1 – General diagram of a system with one input and one output 

 

Systems can be further characterized by certain general properties. Causality refers to the 

temporal sequence of events; in the case of a causal system, the output signal will only change 

as a result of a change in the input signal, a behavior described mathematically in Eq. (1). 

Linearity refers to the linear behavior of the system relative to the input and output signals; if 

the input signal can be linearly decomposed into multiple elementary signals, then the system's 

response to the composite signal will be the same linear combination of the responses to the 

elementary signals, as described in Eq. (2). Time invariance refers to the fact that the initial 

time at which the application of the signals begins does not affect the behavior of the system, 

the behavior modeled in Eq. (3). Stability is perhaps one of the most important characteristics 

of a system for an electronics engineer, referring to the property of the system to produce a 

response bounded in amplitude for a bounded input signal, as seen in Eq. (4); the lack of this 

characteristic in a system can lead to nonlinearities, unwanted oscillations, or even destruction 

of the circuit. 
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Depending on the type of input and output signals, systems can be further divided into 

analog and digital systems. Analog systems are generally made up of diports, electronic circuits 

with an input gate and an output gate that use both passive components such as resistors, 

capacitors and inductors, and active components such as transistors or operational amplifiers. 

Digital systems are generally implemented using either digital circuits, in the form of ASIC 

integrated components or synthesized on FPGAs, or using algorithms running on 



microcontrollers or digital signal processors, and require an interface consisting of digital-to-

analog and analog-to-digital converters to interact with the physical domain. 

Examples of systems that satisfy all of the above properties and are common in electronics 

and telecommunications are filters, amplifiers, audio equalizers, phase shifters, integrators, 

shifters and delay circuits. 

 

1.2 Modeling system response. 

In the case of analog, linear, time-invariant systems, the relationship between the input and 

output signals can be modeled extremely easily by means of a transfer function H(ω), as shown 

in Eq. (5). In the time domain, the same relationship can be modeled by convolving the input 

signal with a weight function h(t), which is the Fourier pair of the transfer function; the time 

relationship between the response of a system and the input signal is given by Eq. (6). 

( ) ( ) ( )Y H X  =  (5) 

( ) ( ) ( )y t h t x t=   (6) 

From Eq. (5), bearing in mind that the Fourier transform of a signal is a complex quantity, 

it can be seen that the amplitude of each spectral component of the input signal will be scaled 

by the modulus of the transfer function at that frequency, as shown in Eq. (7), and to the phase 

of each spectral component will be added a phase shift represented by the argument of the 

transfer function at that frequency, as seen in Eq. (8). 

( ) ( ) ( )Y H X  =   (5) 

 ( ) ( ) arg ( )Y X H    = +  (6) 

There are also certain input signals whose responses carry special status, since they model 

very well the transient response of a system. The first of these responses is the weight function 

h(t) itself, which represents the response of the system to the Dirac impulse x(t) = δ(t), and is 

useful for modeling short-time perturbations at the input of the system. The second is the index 

function a(t), which represents the system response to the unit step function
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low-frequency rectangular signals, for modeling a spontaneous change in the DC component 

of a signal, and similar transient phenomena.  

For example, in the system represented by the RC circuit in Fig. 2, the weight function and 

the index function are plotted in Fig. 3. 

 
Fig. 2 – RC circuit in gamma topology (1st order low-pass filter) 



  
(a) (b) 

Fig. 3 – Weight function (a) and index function (b) for RC circuit in gamma topology (FTJ ord. 1) 

 

A consequence of Eq. (5) and (6) for periodic signals is the so-called harmonic method. 

Since the Fourier transform of any periodic signal can be written according to Eq. (7), the terms 

akc being the coefficients of the Exponential Fourier Series for the periodic signal under 

analysis and ω0 being the fundamental pulse of the periodic signal, from the probing property 

of the Dirac delta Dirac pulses and relation (5) results in relation (8). This being similar to 

relation (7), from Eq. (8) one can extract the Exponential Fourier Exponential Series terms for 

the output signal y(t), as seen in Eq. (9). Consequently, the modulus and phase of each harmonic 

of a periodic signal are found in Eq. (10) and (11). 
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1.2 Using MATLAB Simulink. 

MATLAB Simulink is a graphical programming interface used for modeling and simulating 

dynamic systems. Its interface consists of functional blocks that can be added to the workspace 

and then interconnected using drag and drop.  

To carry out the work, MATLAB R2019 will be used, and the Simulink, Signal Processing 

Toolbox and DSP System Toolbox utilities will be installed by pressing the Add-Ons button as 

shown in Fig. 4, and then searching for them. In order to find them faster, one can use the filters 

in the panel on the left side of the window and select Filter By Source > MathWorks and Filter 

By Type > Toolboxes and Products, as shown in Fig. 5. Checking the installation of the utilities 

can be done by clicking on the arrow below the Add-Ons button in Fig. 4 and then selecting 

Manage Add-Ons, where you can see the installed utilities as shown in Fig. 6. 



 
Fig. 4 – Install and manage MATLAB utilities using the Add-Ons button 

 

 

 

 

 

(a) (b) 
Fig. 5 – Selecting filters in Add-On Explorer 

 

 
Fig. 6 – View installed utilities in Add-On Manager 

 

To open the Simulink utility, you can click on the button labeled as such in the MATLAB 

top menu, also shown in Fig. 4, or type the simulink command in the command console. Then 

create a new model by selecting Simulink > Blank Model in the newly opened window, as 

shown in Fig. 7. 



 
Fig. 7 – Creating a new Simulink model 

 

Before any system can be modeled, Simulink's simulation parameters must be configured 

so that they have a good enough time resolution to simulate the required system. This can be 

done from the Model Settings > Solver > Solver Details menu, which can be opened either by 

using the dedicated button in the Modeling menu, as shown in Fig. 8, or by pressing Ctrl+E. 

Then, unfolding the Solver Details menu, change the maximum simulation step to 1e-4 

(meaning 10-4) and the minimum simulation step to 1e-5 (meaning 10-5), as shown in Fig. 9. 

The rest of the settings are left unchanged. 

 
Fig. 8 – Opening the Model Settings Menu 

 

 
Fig. 9 – Setting the Simulink simulation step 

 



1.3 Modeling an RC circuit with FTJ gamma topology in Simulink and evaluating the 

response for sinusoidal signals. 

The RC circuit modeled will be the one represented in Fig. 2. In order to characterize the 

system, its transfer function must be calculated. From Eq. (5) the relation for the transfer 

function can be deduced ( )
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X(ω) and Y(ω) are voltages, they can be rewritten using Ohm's Law as a function of the current 

I(ω) flowing through both components, resulting in an equation for the transfer function that 

depends only on the values of the components used in the circuit, as can be seen in Eq. (12). 
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(12) 

 

Once the transfer function is known, the system can be modeled, as shown in Fig. 10. As a 

first step, open the component library from the Library Browser menu. Then search in that 

menu and bring Simulink > Sources > Sine Wave, Simulink > Continuous > Transfer Fcn and 

two Simulink > Discrete > Zero-Order Holds into the workspace, which will be connected as 

shown in Fig. 10. To make it easier to find the components, the search menu identified in Fig. 

10 by figure 3 can also be used. To connect the components, drag the mouse over the input and 

output ports of the components, and the arrow that appears is dragged over the port or wire 

with which the connection is desired. 

 
Fig. 10 – Modeling a system in Simulink to evaluate the response to sinusoidal signals 

 

By double-clicking the Sine Wave block, it can be opened, displaying the menu in Fig. 11. 

Set the input sine input signal pulse as ω = 2π-50 (rad/s) . Double-clicking the Transfer Fcn 



block will display the menu in Fig. 12, where the transfer function can be set up as a ratio of 

polynomials, as shown in Eq. (13), using, for convenience, the notation s = jω. 
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Consider the value for the constant RC in Eq. (6) as being 1

2 200 
, meaning that in the 

above expression will be the parameters
0 1 0

1
1, , 1

2 200
a b b


= = =


, values that will be inserted 

in the configuration menu for Transfer Fcn. 

  
Fig. 11 – Sine Wave block configuration Fig. 12 –Transfer Fcn block configuration 

 

To set up the Zero-Order Hold block, open it as in the previous two blocks, and change the 

only parameter present, the sampling time, to double the maximum sampling step, in our case 

2e-4 (or 0.0002). This block represents a sampling circuit found in most digital meters, so we 

can consider it as a part of the spectrum analyzer to be added. This block is also the way to 

adjust the frequency band that can be seen with the spectrum analyzer.  

To complete the diagram in Fig. 10, the blocks Simulink > Sinks > Scope and DSP System 

Toolbox > Sinks > Spectrum Analyzer will be added. In order to visualize both the input and 

output signal, the Scope block must be modified to have 2 inputs. This can be done by opening 

the block as in the previous blocks, opening a window like the one in Fig. 13, clicking on the 

cogwheel image labeled 1 in the figure, and in the Main menu changing the Number of input 

ports from 1 to 2, as shown in Fig. 14. 



 

 

Fig. 13 – Scope block interface Fig. 14 – Changing the number of Scope 
block input ports 

 

In the Time menu, change the displayed time interval from Auto to 0.1 and check the Show 

time-axis label option, as shown in Fig. 15a. In the Display menu, check the Show legend 

option to display the legend from the virtual oscilloscope; here you can also change both the 

title of the figure and the name of the vertical axis, as shown in Fig. 15b. Back in the window 

shown in Fig. 13, click on the trigger button, labeled 2, then change the trigger mode to Normal 

and set the trigger level to 0, turning off the Auto level function, as shown in the figure. 

 

  
(a) (b) 

Fig. 15 – Setting up the two axes of the Scope block 

 

To configure the Spectrum Analyzer's number of inputs, double-click the Spectrum 

Analyzer block, then open the block settings from the File > Number of Input Ports menu, as 

shown in Fig. 16, and change the number of inputs to 2. From the View > Configuration 

Properties menu, display the legend for the Spectrum Analyzer by selecting the Show legend 

option. 

 
Fig. 16 – Setting the number of inputs for the spectrum analyzer 

 



From this point you can finalize the interconnection of the blocks in Fig. 10, and run the 

simulation by pressing the Run button. The simulation results can be seen in Fig. 17 and 18. 

For both the virtual oscilloscope and the virtual spectrum analyzer, you can toggle the display 

of individual signals on and off from the View > Style menu. 

 
Fig. 17 – Input signal and its time response for a gamma RC circuit 

 

 
Fig. 18 – Input signal and its frequency response for a gamma RC circuit 

 

1.4 Using sliders or the Peak Finder function in the spectrum analyzer to measure 

attenuations caused by the transfer function. 

In the spectrum analyzer interface, you can activate the Peak Finder function by selecting 

the button circled in red in Fig. 19a. By changing the number of detected peaks to a value of 2, 

as shown in Fig. 19b, you can measure the amplitude value of the harmonics of the input and 

output signal in decibels by changing the channel on which the measurement is made via the 

selector on the left of the display. 

Exercises: 

Fill in the tables below with data from the sliders or the Peak Finder function. Calculate the 

theoretical value for |H(ω)| using the formula in Eq. (14). Change the transfer function in the 

Transfer Fcn block for the second table. Notice how much is the attenuation in the cells that 

have the thickened contour. What is the relation between the frequencies at which these 

attenuations occur and the RC constant in Eq. (12) 



Table 1: 
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Fig. 19 – Setting up the Peak Finder function of the virtual spectrum analyzer 

 

1.5 Modeling an RC circuit with FTJ gamma topology in Simulink and response 

evaluation for rectangular signals. 

Swap the sinusoidal signal source for a rectangular signal source by bringing the Simulink 

> Sources > Pulse Generator block from the library into the workspace. Then configure the 

block so that the fill factor is 50% and the period is 1/100 (s), as shown in Fig. 20. Set the 

transfer function to be
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. Notice how the first harmonic is affected 

compared to the following harmonics. For visualization with the virtual oscilloscope, set the 

trigger level of the trigger to a positive value between 0 and 1 (e.g., 0.5). 



 
Fig. 20 – Rectangular signal source settings 

 

1.6 RC circuit impulse and step response using Simulink. Weight function and index 

function. 

To determine the system response to the step function, replace the previously used signal 

source with the Simulink > Sources > Step library block, as shown in Fig. 21. Accessing the 

configuration menu of the block, change the time at which the rising edge occurs, meaning the 

parameter τ in the expression σ(t-τ), by changing the Step Time field to the value 1. Change 

the RC constant in the transfer function
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 to take the values 
1

2 50 
, 

1

2 200 
 

and 
1

2 500 
 and observe how the index function a(t) changes.  

To measure the rise time (between 0.1 and 0.9), you can use the sliders in the virtual 

oscilloscope. These can be activated using the button to the right of the trigger button in Fig. 

13. Fill in the table below for the 3 measured RC constant values. 

Table 3 – Index function of the FTJ type RC circuit 

RC 1

2 50 
 

1

2 200 
 

1

2 500 
 

Rise time    

 

 
Fig. 21 – Scheme for determining the index function of a system 

 



In order to determine the impulse response of the system, represented by the weight 

function, a Dirac delta pulse must be provided as input signal. Knowing the relation

( ) ( )
d

t t
dt

 =  to be true, the delta pulse can be generated by deriving the previously used step 

signal by cascading a derivative block, which can be found in the library under Simulink > 

Continuous > Derivatives, as shown in Fig. 22. Change the RC constant with the same values 

as for the index function and observe how the weight function h(t) changes, then fill in the table 

below with the decay time (between the time when h(t) is maximum and the time when h(t) = 

0.1) and the maximum value reached. Adjust the time and value range displayed by the virtual 

oscilloscope as necessary. 

Table 3 - FTJ type RC circuit weighting function 

RC 
1

2 50 
 

1

2 200 
 

1

2 500 
 

Fall time    

max{h(t)}    

 
Fig. 21 – Scheme for determining the index function of a system 

 

1.7 Modeling an RC circuit with FTS gamma topology in Simulink and evaluation of its 

transfer function. 

Model the RC circuit of Fig. 22, whose transfer function is calculated in Eq. (15). 

Reconstruct the scheme used in section 1.4 and 1.5 in Simulink, shown in Fig. 10. Modify the 

Transfer block Fcn so that it models the new transfer function (note that it is necessary to 

specify both the coefficient a1 = RC and the coefficient a0 = 0 in Eq. (13) to specify to Simulink 

that it is required to use a polynomial of degree 1 instead of a constant). Simulate the response 

of the circuit to sinusoidal signals with the pulsations given in the tables below, for RC constant 

values of
1

2 400 
 and 

1

2 800 
. How does this differ from the scenario analyzed in 1.4 and 1.5? 

Measure the attenuation in a similar way as in 1.5. 
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ω [rad/s] 2π·40 2π·80 2π·200 2π·400 2π·800 2π·1000 

|Y(ω)| [dBm]       

|X(ω)| [dBm]       

|H(ω)| = |Y(ω)| - |X(ω)|       

|H(ω)| (theoretical) [dB]       

 

 
Fig. 22 – RC circuit in gamma topology (1st order high-pass filter) 
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(15) 

 

1.8 Modeling an RC circuit with FTS gamma topology in Simulink and response 

evaluation for rectangular signals. 

Rebuild the schematic from section 1.6, except that the transfer function used will be the 

one from the previous section. Reconfigure the Pulse Generator block to set the fill factor to 

50% and the period to 1/100. Simulate the circuit response for RC constant values of 1

2 200 
, 

1

2 400 
 and 1

2 800 
. What happened to the continuous component of the signal? 

 

1.9 Impulse and step response of an FTS RC circuit using Simulink. Weight function and 

index function. 

Proceed similarly as in 1.7 to display the index function and the weight function for the 

system from the previous section. Simulate the circuit response for the values of the constants 

RC
1

2 200 
, 

1

2 400 
 and 

1

2 800 
, and fill in the tables below for the index function with the 

decrease time (between 0.9 and 0.1) and for the weight function with the increase time (between 

the time when the minimum h(t) is reached and the time when h(t) = -0.1). Explain in the weight 



function h(t) what phenomenon occurs at the moment of the momentum δ(t) at the system 

input. 

Table 6 – Index function of FTS type RC circuit 

RC 1

2 200 
 1

2 400 
 1

2 800 
 

Fall time    

 

Tabelul 7 – The weighting function of the FTS type RC circuit 

RC 1

2 200 
 

1

2 400 
 

1

2 800 
 

Rise time    

min{h(t)}    

 

1.10 Modeling a system with the denominator of the second order transfer function in 

Simulink. 

Recreate the scheme in Fig. 10. Set up the Transfer block Fcn to model the transfer function 
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 (note, due to the presence of the unit imaginary term j 
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0 1b = ). An example of a circuit that can have this transfer function can be seen in Fig. 23. 

Using the Peak Finder function in the virtual spectrum analyzer, measure the attenuation 

for the pulsations in the table below and fill it in, similar to the way done in 1.5. Do you notice 

any differences? 

Table 8: 
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ω [rad/s] 2π·50 2π·150 2π·200 2π·400 2π·800 2π·2000 

|Y(ω)| [dBm]       

|X(ω)| [dBm]       

|H(ω)| = |Y(ω)| - |X(ω)|       

|H(ω)| (theoretical) [dB]       

 

 

 
Fig. 23 – Two cascaded RC circuits with intermediate non-inverting repeater 

 



 

1.11 Modeling a phase shifter system in Simulink. 

Recreate the scheme in Fig. 10. Set up the Fcn Transfer block to model the transfer function

1
1

2 200( )
1

1
2 200

j

H

j







−
=

+


. Use the virtual oscilloscope to visualize the system's response to 

sinusoidal signals with pulsations ω = 2π*50, ω = 2π*200, and ω = 2π*800, changing the time 

interval displayed by the oscilloscope so that between 2 and 5 periods are displayed. What 

effect does the system have on the amplitude of the signals? What about their phase? Use the 

sliders and Eq. (16) to determine the delay between the two signals, tx and ty being the times 

when x(t) and y(t) pass through 0 successively on the rising edge, and then to calculate the 

phase shift; finally, fill in the table below. 

Table 9 – FTT phase shifter system 

ω [rad/s] 2π·50 2π·200 2π·800 

ty - tx [s]    

φ(ω)    
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Fig. 24 – Example: Active 1st order FTT phase shifter circuit 
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